Chapter 2.2.6 qpdfview

qpdfview is the default pdf viewer for Lubuntu.

Features:
  • tabs
  • presentation mode
  • zoom to entire page/ page width
  • rotating pages
  • outline, properties, thumbnail, and bookmark docks
  • printing support
  • annotation and highlighting
  • bookmarks
  • customizable keyboard shortcuts

Usage

To open a pdf file use File ‣ Open from the menu or Control + O on the keyboard. If you have a pdf open use File ‣ Open in new tab from the menu, click the Open in new tab button or press Control + T. To refresh a pdf click the Refresh button, File ‣ Refresh, or press F5 just like most web browsers. To switch between tabs on the keyboard you can press control control + tab or Tabs ‣ Next Tab to go the next tab or control + shift + tab or Tabs ‣ Previous Tab to cycle through your tabs in the opposite direction. At the bottom of the tab menu will be a list of all your tabs you have open with the title of each document. To close the tab press the red X button on the tab or press Control +W. To close all tabs on qpdfview press Control + Shift +W. To restore the most recently closed tabs press Alt+Shift+W or Restore most recently closed tab. To view a menu with your recently closed tab Tabs ‣ Recently Closed and select the file you want. To see a list of all your tabs in a menu they are at the bottom of the Tabs menu.

If you want a second copy of a pdf file open right click on the pdf file and Open Copy in new tab. If you want a copy of the current pdf open the pdf file and Open Copy in new window. To open your file manager in the current directory right click on the tab bar and Open Containing Folder. To close all tabs right click on the tab bar and Close all tabs. To Close all tabs but that one you right click on right click on a tab and Close all tabs but this one. To close all tabs to the right of the one you right click right click on a tab and Close all tabs to right. To close all tabs to the left right click on a tab and Close all tabs to left.

If you want to view a particular page select the box (e.g. page 1/3) and type the page number (e.g. page 3/3). To move to the previous and next page use the left and right arrow buttons respectively. There are numerous zoom option, including percentage, page width, page size, continuous, and multiple pages. Another way to jump to a particular page is to press control + j or Edit ‣ Jump to Page. To go back to page which you have just come from press control + enter or Edit ‣ Jump backward. To jump forward a page press control + shift + enter or Edit ‣ Jump Forward.

To print your pdf press Control + P or File ‣ Print. If you are printing the pdf in black and white you can however tpggle previewing the file in black and white by pressing Control + U or View ‣ Convert to grayscale. To invert the colors of your pdf press Control +I or View ‣ Invert Colors. To trim the margins off your pdf file press control +Shift +U or View ‣ Trim margins. If you want to turn any of the alrenetes colors or trimmed margins off press or use the menu in the same thing again.

To select text or an image from qpdfview press control+c or Edit ‣ Copy to clipboard. Then the cursor will turn into a crosshair and you will be able to expand a box to select either text or an image and a menu to select copying the text, selecting the text, copying the image, or saving the image to file. Another way to copy text is to press Shift + Left Click.

To save your pdf file is to File ‣ Save or you can press Control + s. You can save the file with a different name with File ‣ SAve as. To save a copy of the document click File ‣ Save a copy.

qpdfview also includes some very useful docks. To view the outline dock, in the menu select View ‣ Docks ‣ Outline (make sure the button is checked) or press F6 on the keyboard. It should appear on the left hand side of the pdf with collapsible sections. This is useful in navigating large pdfs. To view properties of your pdf file press F7 or View ‣ Docks ‣ Properties. To see a thumbnail of each page View ‣ Dock ‣ Thumbnails or press f8 to view a thumbnail of each page of the pdf file. If you want to close one of these docks click the X button on the dock to close it. To view the fonts embedded in the pdf View ‣ Fonts.

To view two pages at once like if you want to see a two page spread of an illustration in a pdf of a book press Control + 6 or View ‣ Two pages. To get your view back to normal press Control +6 again or View ‣ Two pages again. To toggle the view of three pages at a time press Control +4 or View ‣ Multiple pages. To view right to left languages on qpdfview press Control +Shift +R or View ‣ Right to left.

To search through your pdf file you can press control + f or from the menu Edit ‣ Search. You will get taken to the results and will appear highlighted in yellow to see through the results you can press the down arrow to see results farther in the document and press the upward pointed arrow button to see results towards the start of the document. To exit the view to search dialog press Escape or Edit ‣ Cancel search.

To make qpdfview fullscreen you can press f11 or View ‣Fullscreen . To enter presentation mode you can press f12 or View ‣ Presentation which makes the content of the pdf take up the fullscreen and gives you no menubars or toolbars. To exit presentation mode you can press f12 again. To advance to the next page in the presentation press the spacebar or the right arrow. To go back a page in presentation press the left arrow. To exit the presentation press escape.

To make an annotation press Control +A or Edit ‣ Add annotation. To view the annotation you have made or edit it again press click on what looks like a sticky note with a pin in it. To remove your annotation right click on the annotation and click Remove annotation. If you just want to highlight something right click on the text and select add highlight text.

To select page width in zoom in qpdfview is a drop down menu with page width to show the width of the page on qpdfview, View ‣ Fit to page width, or press Control +9. To view the whole page on qpdfview in this drop down menu select whole page, View ‣ fit to page size, or press Control + 8. To return to the original zoom press Control + 0 or View ‣ Original size. To zoom in is press the magnifying glass with a + in it or press Control + + or View ‣ Zoom in. To zoom out press the magnifying glass button with a - in it or press Control + - or View ‣ Zoom out. To rotate the file to the left is press Control + Left arrow or View ‣ Rotate Left. To rotate the file to the right is press Control + Right arrow or View ‣ Rotate Right.Another way to zoom with the scrollwheel is to press Control and zoom with the mousewheel.

If you want a second copy of a pdf open you can right click on the tabbar Open Copy in new tab. If you want a second copy of a pdf in a new window right click the tab bar Open Copy in new window. To open a file manager in the location of file right click on the tab bar Open Containing Folder. To only leave the tab you right click open and close all other right click the tab bar Close all tabs but this one. To close all tabs to the right of the one you click right click on the tab bar Close all tabs to the right. To close all tabs to the left of the one you click right click on the tab bar Close all tabs to the left.

If you have a particularly long pdf file you might want to make a bookmark to find a specific thing easily. To create a bookmark press control +b or Bookmarks ‣ Add Bookmark and give the bookmark a memorable title and description so you can find it in this document again easily. If you later want to remove the bookmark go bookmarks ‣ remove bookmark or press control+ shift+ B.

To jump to the start of a pdf file press the home key or Edit ‣ First Page. To jump to the last page of a pdf file press the end key or Edit ‣ Last Page. To move to the next page with a keyboard press Spacebar or press Backspace to move back a page.

Screenshot

../../../_images/qpdfview.png

Customizing

To add your own settings to qpdfview you can get to a settings window with Edit ‣ Settings. The checkbox Open URL allows you to turn on or off Opening URLs or links within qpdfview. The Auto-refresh checkbox reloads the pdf whenever the file changes which is useful for authoring pdf files. To open the tabs you had open last time with qpdfview the next time you open the program check the Restore tabs checkbox. If you want to scroll once to change an entire page check the Minimal scrolling checkbox. To change the color of highlights tpye a hex number for a color or select one from the Highlight Color drop down menu.

If you want to reset these settings to the defaults is to press the Defaults button. If you just want defaults on the current tab you can press the Defaults on current tab button. If you want to return to viewing your pdf with the same settings press the OK button. If you wish to discard your changes press the Cancel button.

To deal with settings on graphics press press on the Graphics tab. The settings for paper color will has a drop down menu for previewing what it is like printing on colored paper. The checkbox Prefetch will preload pages not directly viewed by the pdf viewer not directly on the screen however this will use more resources. The drop down for Cache size will increase laoding speed but will use more resources. The Prefetch checkbox loads pages before you view them. The Prefetch distance tells you how many pages away from where you are to load. The field for Presentation background color sets the color of the background for presentations. The Cache size increases the size of the cache which will apply more system resorouces to run heavy pdfs like hundred of pages of full color artwork.

The PDF subtab of the graphics tab has settings for font and paper color for viewing pdf files. To antialias images check the Antialiasing checkbox. To antialias text check the Text antialiasing checkbox. To use font hinting to view text easier to view change the Text hinting menu to Reduced or full.

To change the interface settings click on the Interface tab. If you want the tabs to be spread out press the spread tabs checkbox. The Tab position changes where the tabbar on the window. The Tab visibility menu can be set to as needed, always or never which will show or hide the tabbar. The checkbox for New tab next to current tab opens new tabs next to the current one. The field for recently used lets you set the maximum number of files to keep around in recently used. The Spread tabs checkbox spreads the tabs to take up the whole tab bar and they get smaller the more tabs you open. To have qpdfview close when the last tab in qpdfview is closed check the Exit after last tab checkbox. To change the number of recently used pdf files in the menu change the number in Recently used count field. To change how many recently closed tabs of pdfs are shown change the Recently closed count field.

../../../_images/qpdfviewprefrences.png

The Shortcuts tab provides the ability to customize keyboard shortcuts. The Action column is what is keyboard shortcut does. The Key seqeunce column shows the keyboard shortcut. Double click in the key sequence column and type in your desired keyboard shortcut to change the keyboard shortcut.

Version

Lubuntu ships with version 0.4.17 of qpdfview.

How to launch

To launch qpdfview go to the Menu Office ‣ qpdfview or run

qpdfview

from the command line.