Chapter 2.3.1 lximage

Lximage is the default image viewer for Lubuntu.

Usage

To open a picture press File ‣ Open File, Control + O, or press the button that looks like a opening folder. To open a directory full of images press Control+D or File ‣ Open Directory. If you do not like the picture press Del or File ‣ Delete. To open a new window of lximage press Control +N or File ‣ New Window. To view the properties of your image by File ‣ File Properties. To view your recently viewed pictures File ‣ Recently Opened Files. To reload your file after you save it again press Control +R or File ‣ Reload file.

If you want to upload a picture to share it online press Edit ‣ Upload and a new window will pop up with a drop down menu to show where to upload the picture to. To actually upload the file press Start. The URL of the image will then show up from after it is finished uploading. You can then copy the URL by selecting the text pressing Control+C.

../../../_images/lximage_upload.png

To use lximage use the arrow to the right to view the next file in the folder and the arrow to the left to view the previous folder. To open an entire directory File ‣ Open Directory or press Control +D. To save the file as something press Control+Shift+S or File ‣ Save As. To save the file with the same file name press Control+S or File ‣Save.

If you wish to print a picture after viewing it from the File ‣ Pint or press control+ p to bring up a print dialog. To exit the window with a keyboard shortcut press the Escape key.

To rotate an image to the right press the circular arrow that points to the right, press R, or go to Edit ‣ Rotate Clockwise. To rotate counterclockwise use the circular arrow pointing to the left, press L, or Edit ‣Rotate Counterclockwise. To zoom in on a picture press the icon with a magnifying glass with a + symbol on it, View ‣ Zoom In, or press control + +. To zoom out press the button of a magnifying glass with a - symbol in it, View ‣ Zoom Out or press control + -.

To flip your image on the vertical axis press V or Edit ‣ Flip Vertically. To flip your image on the horizontal axis press H or Edit ‣ Flip Horizontally.

To copy an image to the clipboard you can Edit ‣ Copy to Clipboard. To paste an image to the clipboard Edit ‣ Paste from Clipboard.

To view the next picture on your image press the right arrow or page down and conversely to view the previous image press the left arrow or page up. You can also scroll between different pictures with the mousewheel as well. To jump to the first picture press home or Go ‣ First File. To jump to the last picture press end or Go ‣ Last File.

To view thumbnails of the current directory you can toggle thumbnails by pressing T or View ‣ Show Thumbnails and thumbnails will show at the bottom with a scrollbar at the bottom of the window to view the whole folder. To open the thumbnail of a picture in a another program such as one to edit that picture right click Open click and select the program you want to edit with. To rename an image after viewing it right click on the thumbnail select Rename and type the filename for the picture you want. To move a file to the trash can right click on it and select Move to Trash.

../../../_images/lximage-thumb.png

To view the picture entirely at its original size press View ‣ Fit or the button with a vertical and horizontal arrow and a folded over bottom right corner. To return your image to its original size press the magnifying button with 1:1 inside it or View ‣ Original Size. To show information about the settings on the camera View ‣ Show EXIF Data.

To view the picture as fullscreen press f11 or View ‣ Fullscreen. To have a slideshow of you pictures in your current folder View ‣ Slideshow. Once you start the slideshow on the toolbar a play pause button will appear on the toolbar.

Annotations

To edit your images with lximage there are several buttons on the right hand side of the toolbar. To draw and arrow press the button that looks like an arrow click once where you want the arrow to start and then drag the direction you want the arrow to point and click it where you want the arrowhead to be. To draw a hollow rectangle left click on the button with a hollow rectangle and click and drag to the size of the rectangle you want. To draw a hollow circle annotation press the button that looks like a hollow circle. To draw numbers on your pictures press the 3 button. To stop drawing annotations press the button with a circle with a slash through it.

Screenshot

../../../_images/LXImage.png

Customizing

To change the background color in a window press the button next to Normal background color and then a window will pop up showing your color choice. To change the background color when fullscreen press the button next to Fullscreen background color and the same color picker window will appear. To change how long it takes for a each slide show to change change the Slide show interval (seconds) field. To cancel your changes press the Cancel button. To apply your settings and exit the preference dialog by pressing the OK button.

../../../_images/lximage-prefrences.png

Version

Lubuntu ships with version 0.14.1 or lximage.

How to launch

To launch lximage from the menu Graphics ‣ LXimage or run

lximage-qt

from the command line. The icon for lximage-qt is an orange landscape scene of a sunset.