Chapter 2.4.1 ARK

ARK is a file archive utility. It can be used to view, compress, combine multiple files into one archive, and decompress files.

Supported file formats include:

  • 7 zip archives
  • Java Archive
  • Tar Archives
  • Tar archives compressed with bzip, gzip, lzip, LZMA, XZ compressed
  • Zip Archives

Screenshot

../../../_images/ARK.png

Usage

To open a file in a archive, open the archive, then double click the File ‣ Open button. If you want to extract or move a file from the archive, use the extract button. After you have extracted to places and you have the file open it will appear in in the menu for quick areas to extract to in Archive ‣ Extract All ‣ Quick Extract to. To preview a file press Control +P or File ‣ Preview. To open a file placed in an archive File ‣ Open. To rename a file in an archive press f2 or File ‣ Rename. To delete a file from an archive press Delete or File ‣ Delete and you will have a confirmation so you do not accidentally lose data as this can’t be undone.

To create an archive press Control +N or Archive ‣ New to bring up the create new archive dialog. Enter in the Folder you want to create this archive in the folder or press the folder button on the right to select where to create this archive. Type the Filename of the archive you want to name the file. To select which type of archive you get a drop down menu to select tar or zip archive with various different kinds of compression in the Type drop down menu. Some types of archives will allow to expand tunable settings of compression to change the compression with higher compression but will take more CPU usage to decompress. To automatically add a file extension based on what type of file you have check the Automatically add format checkbox.

../../../_images/arknewarchive.png

To add a file to your archive Archive ‣ Add Files which brings up a file picker to choose how to add files. Once you add a file press the Add button to add a file. If you want to select multiple files to add at once you can hold down Control and then left click on the files.

To view recent archives Archive ‣ Open Recent. To clear the list of recent files Archive ‣ Open Recent ‣ Clear List. To search for files in an archive press Control+F or Archive ‣ Find. To test your archive press Alt +T or File ‣ Test Integrity.

To view the properties of your archive press Alt+ return or Archive ‣ Properties. To see the namme of the archive opened read the Archive Name field. To see what kind of archive you have read the Archive type field. To see the mime-type of your archive read the Mime-type field. To see how the archive is compress read the Compression method(s) field. To see if you have opened something read only read the Opened read-only row. To see if the file is passowrd protected read the Password-protected row. To see the number of files and folder in your archive read the Number of entries row. To see the size of your archive once it is unpacked read the Unpacked size row. To see the size of your archive after compression view the Packed size row. To view the compression ratio on your archive read the Compression ratio row. To see the date the archive was last modified view the Last modified row. To see the different hashes of your archive see the MD5 hash, SHA-1 hash, and SHA-256 hash fields.
../../../_images/ark-prop.png

Version

Lubuntu ships version 4:18.12.3 of ARK.

Customizing

To access your preferences Settings ‣ Configure Ark. To show files in the associated program press the Open file with associated application radio button. To preview with internal previewer press the Preview file with internal previewer radio button. To have a warning when creating a zip file with AES encryption check the Show a warning when creating zip files with AES encryption checkbox.

../../../_images/ark-general-pref.png

To cancel your changes to your settings press the Cancel button. To apply your changes and close the window press the OK button. To currently apply your settings press the Apply button.

The Extraction Settings tab has options for extracting files. To open the destination folder after extraction check the Open destination folder after extraction checkbox. To close ARK after extraction check the Close ARK after extraction checkbox. To have ARK extract to a subfolder if the archive has more than one file or directory at the of the file check the Extract to subfolder if the archive has more than one top-level entry.

../../../_images/arkcustomizing.png

The Plugin Settings tab has settings for each individual plugin. The Name column is the name of the plugin and the Description column is a description of the plugin. To toggle enabling or disabling a plugin check or uncheck the checkbox next to the plugin name in the Name column.

../../../_images/ark-plugin-settings.png

To toggle preview for files larger than a certain size check/uncheck the Disable preview for files larger than checkbox. To change the size of the amount to be previewed change the field to the right of Disable preview for files larger than field.

To see your keyboard shortcuts for ARK Settings ‣ Configure Shortcuts. To see what each individual shortcut does is in the Action column. To see what each keyboard shortcut is Shortcut column. To see what your alternate shortcut for each action see the Alternate column. To change to a custom keyboard shortcut left click on the item in the Action column and press the custom radio button. Then on the button to the right press and input the keyboard shortcut you desire. To restore your keyboard shortcuts to the defaults press the Defaults button.

../../../_images/ark-shortcut-config.png

To switch the language of ARK Help ‣ Switch Application Language. To change the main language change the Primary language drop down field. To then change to this language press the OK button.

../../../_images/ark-language.png

How to Launch

To launch ARK go to the menu Accessories ‣ ARK or run

ark

on the command line. The icon for ARK looks like a green box with a zipper.