Chapter 2.4.2 Featherpad

Featherpad is a lightweight text editor.

It supports:
  • tabs
  • syntax highlighting
  • autoindent
  • autobracket
  • line numbers
  • search with find/replace
  • undo and redo

Usage

If you wish to open a text file press the button that looks like a black and white folder or press control + o to open a file. To view your recently modified files File ‣ Recently modified. To open a new file press the button that looks like a piece of paper with a plus sign. To save your file after typing in the main part of the window press the button that looks like a floppy disk, File ‣ Save, or press control +s. To save a file with a different file name press Control+Shift+S or File ‣ Save As. To show your To reload a file if something else has changed that file in featherpad press the arrow that loops back on itself to reload the page, Control +Shift + R, or File ‣ Reload. If you have unsaved changes to a file an * will show in the tab bar if you have unsaved changes.

To type things into your text file the main part of the window similar to a word processor. If you are programming with featherpad the file extension will probably automatically select the correct syntax highlighting. To view line numbers of the file press control +l or Options ‣ Line Numbers. The line numbers will show the current line highlighted in yellow on the current line. To enable word wrap press Control +W or Options ‣ Wrap Lines and then press the same thing again to turn word wrapping off. To automatically indent lines press Control +I or Options ‣ Auto-Indentation. To toggle document properties press Control + Shift +D or File ‣ Document Properties.

To open a new tab and empty text file press the button with a piece of paper with a plus symbol on it, or press Control + N. If you wish to close a tab press the red x button. To switch between tabs click on the tab is not the close button. To switch to the next tab press Alt + Right arrow or File ‣ Next Tab. To switch to the previous tab press Alt + Left arrow or File ‣ Previous Tab. To close a tab press the X button. To move a tab into a new window press Control + T or File ‣ Detach Tab. To open a side pane that replaces the tab bar press Control +Alt +P or File ‣ Side-Pane. If have so many tabs they don’t all fit in the window press the right and left arrows on the tab bar to move the tab bar that way or use the mousewheel to move the visible tabs in the tab bar. To move to the last text file you had visited press F1 or File ‣ Last Active Tab.

If you have multiple copies of the same file open in Featherpad it will be open read only and shown in yellow. If you want to edit the file even though you have it open you will need to press Control+Shift+E, Edit ‣ Edit, or press the button that looks like a pencil to actually edit the file. You should be careful as the file may not have the contents you expect when editing it in two tabs.

If you want to close all tabs to the left right click on the tab bar Close Previous Tabs. To close all tabs to the right right click on the tab bar Close Next Tabs. To only leave open the tab you right clicked on right click and select Close other tabs. To copy the path to the file you have open right click on the tab bar and select Copy File Path. To copy the file name right click on the tab bar and select Copy File Name.

If you make a mistake and want to undo it press control + z, Edit ‣ Undo, or press the button that looks like a curved arrow pointing towards the left. To redo a change you have undone press the button with a curved arrow pointing towards the right, Edit ‣ Redo, or press Control +Shift +Z.

To select all text in the text file press Control +A or Edit ‣ Select All. To copy text from featherpad press Control +C or Edit ‣ Copy. To paste text press Control+ V or Edit ‣ Paste. To Cut text press Control+X or Edit ‣ Cut. If you have text selected you can delete it by pressing Delete or Edit ‣ Delete. To paste in the date and time press Control + Shift +V or Edit ‣ Paste Date and Time. To go to the end of the current line in the editor press the End key. To move to the start of the current line press the Home key.

To search your text file press Control + f or Search ‣ Find from the menu. Then in the bar on the bottom search for the text you want. Press the down arrow to move to the next result and the up arrow to move for the previous result in the text file. To jump to a particular line in a file press control +j or Search ‣ Jump to or the button that looks like >>. Then in the bar at the bottom type in what line you want to jump to. To find and replace text press control +r or Search ‣ Replace. Type the text you want to Find in the find field and type what you want to put in with the Replace with field and then press enter to finish the finding and replacing through the whole file.

To change what font you want select Options ‣ Font to change your font sizes. To change each font on the on the font level. To change the size type the size you or select it from the Size drop down menu. To select a font style simply use the Font style menu of italic or oblique. To add an underlined font check the Underline checkbox. To view a sample of your font Sample and will preview your text. The input a number of spaces equal to a tab press Control +Tab. To see what the font looks like look in the box under Sample.

../../../_images/featherpad-font.png

To save a file with a different encoding use the Options ‣ Encoding submenu. To save with the current encoding File ‣ Save with Encoding.

To make the text all lowercase first select it with the mouse press then Control + Shift +L or Edit ‣ To Lowercase. To make the text all uppercase select it first then press Control + Shift +U or Edit ‣ To Uppercase. To alphabetize your lines first select it then Edit ‣ Sort Lines. To sort the opposite way first select the lines then Edit ‣ Sort Lines Reversely.

To print a text File ‣ Print or press control + p.

../../../_images/featherpad.png

Customizing

To view the preferences for featherpad press control +Shift +P or Options ‣ Preferences. To change settings on the featherpad window itself are on the Window tab. To remember the size of your window check the Remember window size on Closing checkbox. To start with the side-pane on featherpad check the Start with side-pane mode. To toggle featherpad using its own icons rather than your icon theme check/uncheck the Use own icons checkbox. To hide the toolbar you can press the do not show toolbar checkbox. To not show the menubar by default check the Do not show menubar checkbox. The Tab position moves where the tab around on the screen. To hide the tabbar with only one tab check the Do not show a single tab checkbox. To have the window close after closing the last tab check the Close window on closing its last tab. To have featherpad open a new window when you are on a different virtual desktop check the Always open in seperate windows checkbox. The checkbox Native file dialog uses the systems file dialog to integrate with the system.

../../../_images/featherpadprefrences.png

To change preferences on how text is displayed choose the Text Tab. To have featherpad remember what font you want press the Remember Font checkbox. If you do not want featherpad to highlight syntax by default uncheck the Highlight syntax by default checkbox. If you want to change the be able to change the syntax highlight check the checkbox for Support Syntax override. The checkbox for Always show line numbers always shows line numbers. To have a dark color scheme for featherpad check the Dark Color Scheme checkbox. To change exactly how dark the value of this color is change the Background color value field. After changing the dark theme settings you will need to restart featherpad. The field for Text tab size is how wide to make the tab character. The checkbox for Ensure an empty last line on saving leaves a blank line whenever you save your document. The checkbox for Remove trailing spaces on Saving removes whitespace at the end of lines that is not needed. The checkbox for Thick text Cursor makes the text cursor wider so it much easier to see.

../../../_images/featherpad-text-pref.png

To modify changes to your files from the preferences dialog on Files tab. The Number of recent files field lets you change how many files show in recent files. The set of radio buttons for either Show recently modified files or Show recently opened files for recent files in the menu. If you want to autosave files check the Save changes to files every checkbox and then enter how often you want your files to be automatically saved. If you do not want to be able to open non text files in featherpad check the Do not permit opening of non-text files checkbox. If you want to repopen the files you had last time the next time you open featherpad check the Start with files of last window. If you want featherpad to run executable scripts check the Run executable scripts checkbox. If you want your executable commands to start with something such as an interpreter type the command in the Start with this command field.

../../../_images/featherpad-files-pref.png

To view all keyboard shortcuts of featherpad switch to the Shortcuts tab. The Action column is what the shortcut does and the Shortcut column is the keyboard shortcut to change that shortcut. To change a shortcut double click on the shortcut column and press what you want the shortcut to become. If you changed a setting on a shortcut you can change it back to the default by pressing the Default button.

../../../_images/featherpad-shortcuts.png

Version

Lubuntu ships with version 0.9.3 of Featherpad.

How to Launch

In the menu go to Acessories ‣ Featherpad or run

featherpad

from the command line. The icon for Featherpad looks like a pad of paper with a feather on it.