Chapter 2.2.2 LibreOffice Calc

LibreOffice Calc is the default spreadsheet program for Lubuntu.

Usage

To move between cells press the arrow keys. To enter data into cells type in the keyboard. To select cells left click and drag to select the cells you want. To sum data from cells in the cell where you want the sum is to press the button that looks like Σ character and then drag the mouse over the cells you want to add. To sort your cells in descending order press the button with bullet points and an arrow going down. To sort in ascending order press the button with bullet points and an arrow pointing upwards.

../../../_images/calc-save.png

To save your spreadsheet you need to press the button that looks like a floppy disk, press the keyboard shortcut or go to File ‣ Save. To save with a different file name File ‣ Save as. To open a file press the button that looks like a brown folder and add select the file you want from the dialog or File ‣ Open. To open a recent document File ‣ Recent Documents.

To copy data you can right click Copy, press the button with two pieces of paper or press control + c. To paste data press control control +v, Edit ‣ Paste, right click Paste, or press the button that is a clipboard with a piece of paper on it. To cut text press control+x or press the scissors button to cut text. If you want to paste your text unformatted press Control+Shift + Alt+V or Edit ‣ Paste Unformatted Text.

To change to showing currency for the number press Control+Shift+4 or Format ‣ Number Format ‣ Currency. To change to percentage press Control+Shift+5 or Format ‣ Number Format ‣ Percentage. To switch back to a normal number press Control+Shift+1 or Format ‣ Number Format ‣ Number.

To view values highlighted in another color to see them easier press Control+F8 or View ‣ Value Highlighting.

To view a long list of functions to use View ‣ Function List. To select different functions left click on the function name in the column. To insert a function press the fx button. To sort by different categories of functions use the drop down menu to the right of the fx button. To close this function sidebar press the x button.

To see a gallery of stock images for your spreadsheet View ‣ Gallery. To get a list of different categories of images beneath Galleries and left click to select your image. To move an image in from the gallery to your spreadsheet left click on the image and drag the image to where you want.

To style part of your spreadsheet to bring lots of attention to a cell Styles ‣ Accent 1. To bring slightly less attention to a cell Styles ‣ Accent 2. To bring even less attention to a cell Styles ‣ Accent 3. To style a cell like a heading Styles ‣ Heading 1. To have a slightly smaller heading Styles ‣ Heading 2. To switch back to your original style Styles ‣ Default.

To insert an image press Insert ‣ Image. To select an image to change how it appears in your spreadsheet left click on it. To resizing your image while keeping the same aspect ratio click on the box on the corner of your image. To stretch or shrink an image horizontally left click on the boxes on the left or right hand side and then release when in the giant position. To stretch on shrink your image vertically click on the box on the top or bottom and drag to your desired position.

If you want to insert a new column to the left of a column right click on the letter for the column Insert Column Before. If you want the new column to the right is right click on the letter and Insert Column After. To insert a row above the current row right click on the number and Insert Row Above. To insert a row below the current row right click on the number and Insert Row Below. To delete a row or column right click the number and select Delete rows or Delete Column.

To change the size of a row or column of cells click in between the border of that particular row or column and drag with the mouse to give yourself room.

To sort your data like a bunch of names first select all the cells with the mouse Data ‣ Sort Ascending. If you want the reverse order to this you can have Data ‣ Sort Descending.

To undo a selection press control +z or press the button with the arrow looping around and pointing to the left. To redo an operation press Control +y or the number looping to the right and exiting to the left.

To zoom to view a full page on your spreadsheet in the menu View ‣ Zoom ‣ Entire Page. To view the whole width of your page on the menu View ‣ Zoom ‣ Page Width. To zoom to a particular percentage View ‣ Zoom and select the percentage you want.

../../../_images/libreoffice_calc.png

To select all cells in your spreadsheet press Control+A. To select an entire column press Control+Space or Edit ‣ Select ‣ Select Column. To select an entire row press Shift +Space or Edit ‣ Select ‣ Select Row.

To create a new spreadsheet in the same file press the button on the bottom that looks like a + or Sheet ‣ Insert Sheet. To switch between each sheet press the button on each sheet at the bottom near the button to add a new sheet.

To insert a special character not on your keyboard Insert ‣ Special Character. To select what character to insert left click in the center of the inserting character window. To actually insert the symbol press the Insert button.

To quit LibreOffice Calc press Control+Q.

Charts

To get to the dialog of how to insert a chart Insert ‣ Chart. The first selection is to choose a Column, Bar, Pie, Area, Line, XY(Scatter), Bubble, Net, Stock, or Column and Line chart. To change the subtype of graph click the picture of a chart that looks like the type you want. To switch to the next step of making a graph press the Next button.

../../../_images/chartwindow.png

The Data Range tab controls what data will be in the chart and how present it. To switch to basing the bottom axis of your chart on rows of data press the Data series in rows button. To choose to switch your bottom axis of your chart on columns press the Data series in columns button. To use the first row as a label on each item on the chart check the First row as label checkbox. To input a custom title on the first column of your chart check the First column as Label checkbox.

../../../_images/chart-data-range.png

The Chart Elements tab controls labels and displaying legends on your chart. To add a title to your chart type your title in the Title field. To add a subtitle to your chart type it in the Subtitle field. To add a label to your horizontal axis type your label in the X axis field. To label your vertical axis type your label in the Y axis field. To have a vertical grid lines on your chart check the X axis checkbox. To have horizontal lines on your grid check the Y axis checkbox. To toggle displaying a legend on your graph check the Display legend checkbox. To move the legend to the left hand side press the Left button. To move the legend to the right hand side press the Right button. To move the legend to the top of the chart press the Top button. To move the legend to the bottom of the chart press the Bottom button.

../../../_images/chart-elements.png

Version

Lubuntu ships with version 6.3.1.2 of LibreOffice Calc.

How to Launch

To launch LibreOffice Calc from the menu go to Office ‣ LibreOffice Calc or run

localc

from the command line.