Chapter 2.2.2 Libreoffice Calc

Libreoffice Calc is a spreadsheet program included by default in Lubuntu.

Usage

To move between cells press the arrow keys. To enter data into cells type in the keyboard. To select cells left click and drag to select the cells you want. To sum data from cells in the cell where you want the sum is to press the button that looks like Σ character and then drag the mouse over the cells you want to add. To sort your cells in descending order press the button with bullet points and an arrow going down. To sort in ascending order press the button with bullet points and an arrow pointing upwards.

../../../_images/libreoffice_calc.png

To save your spreadsheet you need to press the button that looks like a floppy disk, press the keyboard shortcut or go to File ‣ Save. To save with a different file name File ‣ Save as. To open a file press the button that looks like a brown folder and add select the file you want from the dialog or File ‣ Open. To open a recent document File ‣ Recent Documents.

To copy data you can right click copy, press the button with two pieces of paper or press control + c. To paste data press control control +v, edit ‣ paste, right click paste or press the button that is a clipboard with a piece of paper on it. To cut text press control+x or press the scissors button to cut text. If you want to paste your text unformatted press Control+Shift + Alt+V or Edit ‣ Paste Unformatted Text.

To change to showing currency for the number press Control+Shift+4 or Format ‣ Number Format ‣ Currency. To change to percentage press Control+Shift+5 or Format ‣ Number Format ‣ Percentage. To switch back to a normal number press Control+Shift+1 or Format ‣ Number Format ‣ Number.

To view values highlighted in another color to see them easier press Control+F8 or View ‣ Value Highlighting.

To insert an image press Insert ‣ Image. To get to the dialog of how to insert a chart Insert ‣ Chart. The first selection is to choose a column, bar, Pie, Area, Line, XY(Scatter), Bubble, Net, Stock, or Column and Line chart. To change the subtype of graph click the picture of a chart that looks like the type you want.

../../../_images/chartwindow.png

If you want to insert a new column to the left of a column right click on the letter for the column Insert Column Before. If you want the new column to the right is right click on the letter and Insert Column After. To insert a row above the current row right click on the number and Insert Row Above. To insert a row below the current row right click on the number and Insert Row Below. To delete a row or column right click the number and select Delete rows or Delete Column.

To change the size of a row or column of cells click in between the border of that particular row or column and drag with the mouse to give yourself room.

To sort your data like a bunch of names first select all the cells with the mouse Data ‣ Sort Ascending. If you want the reverse order to this you can have Data ‣ Sort Descending.

To undo a selection press control +z or press the button with the arrow looping around and pointing to the left. To redo an operation press Control +y or the number looping to the right and exiting to the left.

To zoom to view a full page on your spreadsheet in the menu View ‣ Zoom ‣ Entire Page. To view the whole width of your page on the menu View ‣ Zoom ‣ Page Width.

To select all cells in your spreadsheet press Control+A. To select an entire column press Control+Space or Edit ‣ Select ‣ Select Column. To select an entire row press Shift +Space or Edit ‣ Select ‣ Select Row.

To create a new spreadsheet in the same file press the button on the bottom that looks like a + or Sheet ‣ Insert Sheet. To switch between each sheet press the button on each sheet at the bottom near the button to add a new sheet.

To insert a special character not on your keyboard Insert ‣ Special Character. To select what character to insert left click in the center of the inserting character window. To actually insert the symbol press the Insert button.

Version

Lubuntu ships with version 6.2.2.2 of libreoffice Calc.

How to launch

To launch libreoffice calc in the menu go to Office ‣ Libreoffice Calc or run

localc

from the command line.