Chapter 2.4.2 Featherpad

Featherpad is Lubuntu’s default lightweight text editor.

It supports:
  • Tabs
  • Syntax highlighting
  • Autoindent
  • Autobracket
  • Line numbers
  • Search with find/replace
  • Undo and redo
  • Spellcheck

Usage

To open a new file press the button that looks like a piece of paper with a plus sign, press Control+N, or File ‣ New. If you wish to open a text file press the button that looks like a folder, File ‣ Open, or press control + o. To open your recently modified files File ‣ Recently modified. To save your file after typing in the main part of the window press the button that looks like a floppy disk, File ‣ Save, or press control +s. To save a file with a different file name press Control+Shift+S or File ‣ Save As. To show your To reload a file if something else has changed that file in Featherpad press the arrow that loops back on itself to reload the page, Control +Shift + R, the button that looks like a browser refresh button, or File ‣ Reload. If you have unsaved changes to a file an * will show in the tab bar if you have unsaved changes.

To type things into your text file the main part of the window similar to a word processor. If you are programming with Featherpad the file extension will probably automatically select the correct syntax highlighting. To toggle syntax highlighting press Control+Shift+H or Options ‣ Syntax Highlighting. To view line numbers of the file press control +l or Options ‣ Line Numbers and do the same thing to turn it off. The line numbers will show the current line number in yellow. To enable word wrap press Control +W or Options ‣ Wrap Lines and then press the same thing again to turn word wrapping off. To automatically indent lines press Control +I or Options ‣ Auto-Indentation. To toggle document properties press Control + Shift +D or File ‣ Document Properties.

To open a new tab and empty text file press the button with a piece of paper with a plus symbol on it, or press Control + N. If you wish to close a tab press the red x button. To switch between tabs click on the tab is not the close button. To switch to the next tab press Alt + Right arrow or File ‣ Next Tab. Another way to open a new document in a new tab double click to the right of all open tabs. To switch to the previous tab press Alt + Left arrow or File ‣ Previous Tab. To close a tab press the X button. To move a tab into a new window press Control + T or File ‣ Detach Tab. To open a side pane that replaces the tab bar press Control +Alt +P or File ‣ Side-Pane. If have so many tabs they don’t all fit in the window press the right and left arrows on the tab bar to move the tab bar that way or use the mousewheel to move the visible tabs in the tab bar. To move to the last text file you had visited press F1 or File ‣ Last Active Tab. To change to your last tab press Alt+ Up arrow or File ‣ Last Tab. To change to your first tab press Alt+ Down arrow or File ‣ First Tab.

../../../_images/featherpad-sidebar.png

If you have multiple copies of the same file open in Featherpad it will be open read only and shown in yellow. If you want to edit the file even though you have it open you will need to press Control+Shift+E, Edit ‣ Edit, or press the button that looks like a pencil to actually edit the file. You should be careful as the file may not have the contents you expect when editing it in two tabs or editors.

To make text in Featherpad bigger press Control+ + or hold Control and move the mousewheel up. To make text in Featherpad smaller press Control+ - or hold Control and move the mousewheel down.

If you want to close all tabs to the left right click on the tab bar Close Previous Tabs. To close all tabs to the right right click on the tab bar Close Next Tabs. To only leave open the tab you right clicked on right click and select Close Other Tabs. To copy the path to the file you have open right click on the tab bar and select Copy File Path. To copy the file name right click on the tab bar and select Copy File Name. To reorder your tabs left click and drag the tab to where you want it. To open the folder the file is in a fire manager right click and select Open Containing Folder.

../../../_images/featherpad-tab-context.png

If you make a mistake and want to undo it press control + z, Edit ‣ Undo, or press the button that looks like a curved arrow pointing towards the left. To redo a change you have undone press the button with a curved arrow pointing towards the right, Edit ‣ Redo, or press Control +Shift +Z. To input a number of spaces equal to a tab press Control +Tab.

To select all text in the text file press Control +A, right click Select All, or Edit ‣ Select All. To copy text from Featherpad press Control +C, right click Copy, or Edit ‣ Copy. To paste text press Control+ V, right click Paste or Edit ‣ Paste. To Cut text press Control+X, right click Cut, or Edit ‣ Cut. If you have text selected you can delete it by pressing Delete or Edit ‣ Delete. To paste in the date and time press Control + Shift +V or Edit ‣ Paste Date and Time. To go to the end of the current line in the editor press the End key. To move to the start of the current line press the Home key.

To search your text file press Control + f, the magnifying glass button, or Search ‣ Find from the menu. Then in the bar on the bottom search for the text you want. Press the down arrow to move to the next result and the up arrow to move for the previous result in the text file. To not make the search case sensitive press the Aa button or press F5. To only match whole words press the button or press F6. To use a regular express press the Rx button or press F7. To make the search not case sensitive, whole word, or use a regular expression press the same button to turn that off.

../../../_images/featherpad-find.png

To jump to a particular line in a file press control +j or Search ‣ Jump to or the button that looks like >>. To select the text you jump to press the Select Text button. To jump to a particular line type the line number in the Go to line field.

../../../_images/featherpad-jump.png

To find and replace text press control +r, the button with a magnifying glass and a pencil, or Search ‣ Replace. Type the text you want to Find in the find field and type what you want to put in with the Replace with field and then press enter to finish the finding and replacing through the whole file.

../../../_images/featherpad-find-replace.png

To change what font you want select Options ‣ Font to change your font sizes. To choose a font that is not fixed width uncheck the Programming Fonts checkbox. To change the font use the Font field. To change font size change the Size field. To change the font weight use the Weight drop down menu. To view a sample of your font Preview and will preview your text.

../../../_images/featherpad-font.png

To save a file with a different encoding use the Options ‣ Encoding submenu. To save with the current encoding File ‣ Save with Encoding.

To make the text all lowercase first select it with the mouse press then Control + Shift +L or Edit ‣ To Lowercase. To make the text all uppercase select it first then press Control + Shift +U or Edit ‣ To Uppercase. To alphabetize your lines first select it then Edit ‣ Sort Lines. To sort the opposite way first select the lines then Edit ‣ Sort Lines Reversely.

To print a text File ‣ Print or press control + p. To change which printer you use have use the Name field. To get more options for printing press the Options button. To change how many copies to print change the number in the Copies field. To print on a certain range of pages use the Pages From field to choose a range of pages.

../../../_images/featherpad-print.png

To run an executable script press Control+E. To quit Featherpad press Control+Q.

../../../_images/featherpad.png

Spellcheck

To open a spell check window press F2 or Edit ‣ Check Spelling. If the spell check does not find a what you typed that spellcheck does not recognize will be shown from Unknown word followed by what is typed. If this is correct press the Add To Dictionary button to never have to deal with spellcheck marking this wrong again. To see what is wanted as a replacement for a typo see Replace with for the first suggestion and beneath this is a list of things to replace with. To choose a different suggestion left click on the suggestion to switch to it. To correct this typo just once press the Correct Once button. To correct this spell check every single time in your file press the Correct All button. To not change what you have typed in just this case press the Ignore Once button. To ignore what you have typed press in the entire file press the Ignore All button. If you do not have a spelling error on the bottom will appear a red bar saying No misspelling from text cursor.

../../../_images/Featherpad-spellcheck.png

Saving Sessions

To open all the files if you work on several together in a session press Control+M or File ‣ Save/Restore Session and a dialog will appear. To save your first session type a name to remember this and then press the Save button. To open your saved session click the name of the session on the top of the dialog and then press Open. To remove a saved session press the Remove button. To remove all saved session press the Remove All button. To search for a particular session type in the Filter section. To include saving tabs from other windows in your session uncheck the Save only in this window checkbox.

../../../_images/featherpad-session-save.png

Customizing

To view the preferences for Featherpad press control +Shift +P or Options ‣ Preferences. To change settings on how Featherpad handles the window use the Window tab. To have Featherpad be the same size as when you last closed it check the Remember window size on Closing checkbox. If you choose for Featherpad not to remember size you can change Start with this size field for height and width to start Featherpad. To have Featherpad appear on the same position it was when Featherpad was closed check the Remember window position on closing checkbox. To start with the side-pane on Featherpad check the Start with side-pane mode. To toggle Featherpad using its own icons rather than your icon theme check/uncheck the Use own icons checkbox. To hide the toolbar you can press the Do not show toolbar checkbox. To not show the menubar by default check the Do not show menubar checkbox.To have the searchbar hidden by default check the Hide search bar by default checkbox. The Tab position menu moves where the tab around on the screen. To hide the tabbar with only one tab check the Do not show a single tab checkbox. To have the window close after closing the last tab check the Close window on closing its last tab. To have Featherpad open a new window when you are on a different virtual desktop check the Always open in separate windows checkbox. The checkbox Native file dialog uses the systems file dialog to integrate with the system.

../../../_images/featherpadprefrences.png

To change preferences on how text is displayed choose the Text Tab. To have Featherpad remember what font you want press the Remember Font checkbox.To have your Featherpad wrap lines if your line is too long by default check the Wrap lines by default checkbox. To have Featherpad automatically indent new lines by default check the Auto-indent by default checkbox. To have Featherpad automatically insert closing brackets check the Auto-bracket checkbox. To have Featherpad replace triple periods and double hyphens with other characters representing the same thing check the Replace triple periods and double hyphens while typing checkbox. The checkbox for Always show line numbers always shows line numbers.

If you do not want Featherpad to highlight syntax by default uncheck the Highlight syntax by default checkbox. If you want to change the be able to change the syntax highlight check the checkbox for Support Syntax override. To have Featherpad not highlight overly large text files change the Never highlight syntax for files > field. To have Featherpad show a dot for whitespace check the Show whitespaces checkbox. To show formatting marks when there is a line and paragraph ends check the Also who line and document ends checkbox. To show To have a dark color scheme for Featherpad check the Dark Color Scheme checkbox. To change exactly how dark the value of this color is change the Background color value field. After changing the dark theme settings you will need to restart Featherpad.

The field for Text tab size is how wide to make the tab character. The checkbox for Ensure an empty last line on saving leaves a blank line whenever you save your document. The checkbox for Remove trailing spaces on Saving removes whitespace at the end of lines that is not needed. The checkbox for Thick text Cursor makes the text cursor wider so it much easier to see. To have your scrolling have inertia to keep scrolling the faster you scroll check the Inertial scrolling with mouse wheel checkbox. To change where Featherpad looks for a dictionary for spell checking change the Hunspell dictionary path field. To start spell checking from your current text cursor check the Start spell checking from text cursor checkbox.

../../../_images/featherpad-text-pref.png

To modify changes to your files from the preferences dialog on Files tab. The Number of recent files field lets you change how many files show in recent files. The set of radio buttons for either Show recently modified files or Show recently opened files for recent files in the menu. To clear your list of recent files File ‣ Recently Modified ‣ Clear. If you want to reopen the files you had last time the next time you open Featherpad check the Start with files of last window. If you want Featherpad to run executable scripts check the Run executable scripts checkbox. If you want your executable commands to start with something such as an interpreter type the command in the Start with this command field. If you want to autosave files check the Save changes to files every checkbox and then enter how often you want your files to be automatically saved. If you do not want to be able to open non text files in Featherpad check the Do not permit opening of non-text files checkbox.

../../../_images/featherpad-files-pref.png

To view all keyboard shortcuts of Featherpad switch to the Shortcuts tab. The Action column is what the shortcut does and the Shortcut column is the keyboard shortcut to change that shortcut. To change a shortcut double click on the shortcut column and press what you want the shortcut to become. If you changed a shortcut you can change it back to the default by pressing the Default button.

../../../_images/featherpad-shortcuts.png

To change what colors you use in syntax highlighting use the Syntax Colors tab. To change the color of built in functions click the color to the right of Built-in Functions and a window to pick your color will show up. To change the color of comments in syntax press the button next to Comments and a color picker window will pop up. To change how documents HTML or xml elements appear change the press the button next to Document Blocks, XML/HTML Elements button to have a color selection window appear. To change how extra elements are colors press the button next to Extra Elements. To change the color of functions and URLs in highlighting press the button next to Functions, URLs. To change how keywords of a programming language appear press the button next to Keywords. To change the color of markdown headings and css values press the button next to Markdown Headings, Css Values. To change how numbers are highlighted press the button next to Numbers. To change how quotations are highlighted press the button next to Quotations. To change how you highlight regular expressions and code blocks press the button next to Code Blocks. To change how datatypes are highlighted press the button next to Types. To change how dark the whitespace appears in highlighting change Whitespace color value. To change how dark the currently highlighted line is change Current line highlight value. To restore syntax highlighting to default values press the Default button.

Version

Lubuntu ships with version 0.17.1 of Featherpad.

How to Launch

To launch Featherpad from the menu go to Accessories ‣ Featherpad or run

featherpad

from the command line. The icon for Featherpad looks like a blue circle for with a pencil on it.